Upgrade mini V1 mit Esp32 Modul und SSR

s.ochs

BOFH
Teammitglied
Gern! Solltest du irgendwann doch mal das Addon verbauen, musst du die Kanäle über den selben Weg wieder aktivieren, nur dass dann im Textfile ein false anstelle von dem true stehen muss. Oder du machst einen Reset aller Einstellung auf Werkseinstellung.
 

Klappi

New member
Gern! Solltest du irgendwann doch mal das Addon verbauen, musst du die Kanäle über den selben Weg wieder aktivieren, nur dass dann im Textfile ein false anstelle von dem true stehen muss. Oder du machst einen Reset aller Einstellung auf Werkseinstellung.
Vielen Dank für diese Info werde ich in meinem Ordner abspeichern
LG Klappi
 

lemuba

Member
Also du warst mit deinen Werten gestern gar nicht so weit weg, aber ... ideal ist die Regelstrecke auch noch nicht. Da ist eine ziemlich große Verzögerung von gut 10 °C nach Abschalten der Heizquelle drin, das macht ein dynamisches Einregeln schwierig.

Anhang anzeigen 4327

Für die aktuelle Strecke wären passende Werte:
Kp = 8, Ki = 0,01, Kd = 150
Aber ganz glatt wird das damit vermutlich nicht. Wäre die Frage, ob man diese Verzögerung noch weg bekommt. Entweder kommt sie davon, dass die Quelle selbst nach Abschalten noch nachheizt oder das die Energie erst verzögert an der Messstelle ankommt. Wo genau sitzt der Sensor und wie weit ist der Weg von der Quelle? Ist da was dazwischen?

Der Rauchgenerator scheint in gewissem Maße auch Energie zuzuführen, da wird sich ein ein/aus auch leicht auf das Regelverhalten auswirken.
Weißt du was gegen 11 Uhr war?

Was ist das bei Kanal 3 für ein Fühler? Der ist sehr unruhig. Die Platine hast du selbst gelötet? Da tauchen in der Cloud immer mal wieder ungenutzte Kanäle aus. Das könnten nicht ganz sauber gereinigte Anschlüsse sein.


Hallo Allerseits, ich hänge mich mal hier ran....
Haben nun mein ESP-Mini v2 auch mal wieder am Start für heute Nacht, ebenfalls an meinem Beketal-Smoker.
Nun mit der aktuellen v1.1.0 Firmware. Die oben genannten Werte passen auch bei mir schon ganz gut. Aber hat sich irgendetwas an den Pitmaster-Einstellungen geändert, dass nun DC-Min und DC-Max Werte nicht mehr greifen? Hatte noch Anfang des Jahres immer DC-Min auf 20%, in der Hinsicht, dass ich nicht wollte, dass die Heizung komplett aus geht, was auch immer gut im Zuge der Regelung funktioniert hatte. Nun trotz 20%, geht die Regelung bis auf auf 0% runter...?
 

s.ochs

BOFH
Teammitglied
Nicht verwechseln: Der Pitmasterwert ist ein relativer Wert der immer von 0 - 100 % geht, und zwar relativ in dem Bereich, der durch DCmin und DCmax aufgespannt wird. Die DC-Werte wiederum sind absolut und beziehen sich auf physikalische Umsetzung des Steuersignal. Bei FAN ist es also die Spannung, die maximal im Bereich von 0 - 12V (0 - 100 %) sein. Und bei SSR und Servo ist es die Breite des PWM-Signals.
 

lemuba

Member
Danke für´s schnelle Feedback! Es läuft mal wieder absolut hervorragend. DC-Min und Max. habe ich nun auf Standartwerte belassen und wie festgesstellt, macht auch die Deckelüberwachung bei einem Elektrosmoker keinen Sinn, also deaktiviert. Anbei, auch für meine eigenen Notizen, entsprechende Werte. Ich wünsche Euch Allen einen guten und gesunden Rutsch ins neue Jahr!

IMG_1608.jpg

IMG_1609.jpg

IMG_2230.jpg

IMG_2231.jpg
 

s.ochs

BOFH
Teammitglied
Gutes Gelingen!
Du hast sehr viel "Unruhe" auf der Messung, was sich auch auf den Pitmaster auswirkt. Welche Fühler sind das? Eventuell hast du da eine kleine Erdungsschleife drin.
 

lemuba

Member
Ja, der eine Maverik Fleischfühler rauscht ein wenig, liegt aber m.e. nur am Fühler. Hatte ich die letzten Male auch schon, aber letztendlich war das Ergebnis immer top. Falls der Fühler mal ganz aussteigt, habe ich hier noch Ersatz liegen... Habe den noch nicht im Einsatz, da ich noch keine Distanz Kunststoff Mutter wie bei den anderen Fühlern am Stecker angeklebt habe.

PS. Bei höheren Temps am Fleischfühler >70 Grad ging das Rauschen dann auch weg...
 

s.ochs

BOFH
Teammitglied
Ah ok, du hast die originalen Maverick. Das erklärts. Die Fühler sind ok, denen fehlt aber der GND-Kontakt auf dem Kabelschirm, daher kommt die Erdungsbrücke zusammen mit dem Einsatz des Pitmasters. Nicht weiter wild, aber deshalb sieht dein Pitmastersignal so zappelig aus. Ist auf Dauer auch nicht ideal für den Aktor. Eine kleine Kabelbrücke vom Kabelschirm des Fühlers zum hinteren Kontakt des Steckers sollte da schon Abhilfe schaffen. Etwa so:

IMG_20180704_104924284.jpg
 
Oben Unten