• SHOP-INFO: Die Auslieferung der WLANThermo Mini V3 Bestellungen aus dem Februar hat seit dem 01.03.2021 begonnen. Die Bestellungen werden der Reihe nach anhand des Bestelldatums bearbeitet und verschickt. Jeder Besteller wird informiert sobald seine Bestellung an der Reihe ist.

Passwords

Hydropower

New member
Hi,
It seems like I'm the only non-german guy here (Swedish), but with the thing you guys got going on I think that's just a matter of time! I heard about the wlanThermo on the openHAB forum and it took me less than 10min to decide I needed this! I'm an electronics/embedded engineer as a profession and Kamado griller in spare time so I have fed the idea to make something like this myself, but never found the time...
Now, to my (first) question:
When I added the cloud connection I had to enter a username/password of admin/admin (found using google translate on the wlanthermo.de page). So I got the cloud connection up and running. But I'm not that fond of leaving a password with admin/admin! So how do I change that? I found something about a /admin page, but when I go to <IP of nano v1+>/admin i get a quick form (in german...) asking me for a new password (max 10 chars). After entering 10 chars and pressing the button I get redirected to /setadmin instead of admin and there I get an error 404, no such page... Am I on the wrong path or is there a bug?

Best regards
Henrik Kjellberg
 

s.ochs

BOFH
Teammitglied
Hi Henrik, welcome to our community!
Yes, it's a bug. If you currently want to change the password, you must manually send a POST request to /admin, with autentification and parameter "wwwpw", e.g. with Postman.
Steffen
 

Hydropower

New member
Hi Henrik, welcome to our community!
Yes, it's a bug. If you currently want to change the password, you must manually send a POST request to /admin, with autentification and parameter "wwwpw", e.g. with Postman.
Steffen
Ok, thanks for verifying.
I assume we are taking about a REST command?
 

s.ochs

BOFH
Teammitglied
Yes. The button normally sends a POST request with the content of the field as parameter "wwwpw" to IP/admin. Currently sent to IP/setadmin, that doesn't work. So you have to create the POST request manually and send it to IP/admin. Or you are waiting for the next update, where the bug will be fixed.
 
Oben Unten