• SHOP-INFO: Nachschub für unser WLANThermo Mini V3 ist eingetroffen. Somit kann es ab dem 30.07.2021 wieder bestellt werden. Die Auslieferung der Bestellungen beginnt ab dem 06.08.2021. Wir bedanken uns herzlich für euer geduldiges Warten!

Welche Widerstände für PT100/PT1000

MacLitze

New member
Moin!

Habe schon seit längerem einen Mini V1. Hatte mir den fertig aufgebaut schicken lassen. Ich hatte mir für Kanal 7 und 8 (nach ESP Upgrade) andere Widerstände für PT100 bzw. PT1000 einbauen lassen. Wenn ich den Farbcode richtig deute hat
- Kanal 7: 100 Ohm
- Kanal 8: 1 kOhm
Welcher Fühler gehört jetzt an welchen Widerstand?
PT100 an Kanal 6 (100Ohm, Fühlereinstellung PT100) zeigt mir 32°C bei 19°C Referenztemperatur
PT100 an Kanal 7 (1kOhm, Fühlereinstellung PT100) wird gar nicht angezeigt.
PT1000 an Kanal 6 (100kOhm, Fühlereinstellung PT1000) wird nichts angezeigt
PT1000 An Kanal7 (1kOhm, Fühlereinstellung PT1000) wird 13,5 bei 19°C Referenztemperatur

Irgendjemand eine Idee wo ich den Fehler habe?

Gruß Kay
IMG_1318.jpeg
 

s.ochs

BOFH
Teammitglied
Admin
Wenn ich das richtig gelesen habe, dann hat @MacLitze den ESP32 drin. Dort kann er die Referenzwerte nicht wie beim Pi in der config anpassen sondern nur direkt im Firmware-Code. In der Software vom ESP32 wird von einem gemeinsamen Referenzwiderstand aus parallel 47K und 1K ausgegangen, wie er entsteht, wenn der 1K parallel zum bestehenden 47K eingelötet wird. So ist es auf der Mini V2 Platine der Fall, hier wurde aber der 47K durch den 1K komplett ersetzt, daher passt hier jetzt der Wert in der Software nicht. Da der resultierende Wert unter 1 kOhm liegt, ist auch die berechnete Temperatur tiefer als real, das erklärt das Verhalten des PT1000. Die zu hohe Temperatur beim PT100 erklärt das allerdings nicht, hier könnte noch etwas anderes reinspielen.
 

Nixarbeit

Member
Hast du den Pie noch zum Testen? Dann könnte mal den ja mal draufstecken. Entsprechend die Werte einstellen und sehen ob's dann passt.

Wenn ich das richtig gelesen habe, dann hat @MacLitze den ESP32 drin. Dort kann er die Referenzwerte nicht wie beim Pi in der config anpassen sondern nur direkt im Firmware-Code. In der Software vom ESP32 wird von einem gemeinsamen Referenzwiderstand aus parallel 47K und 1K ausgegangen, wie er entsteht, wenn der 1K parallel zum bestehenden 47K eingelötet wird. So ist es auf der Mini V2 Platine der Fall, hier wurde aber der 47K durch den 1K komplett ersetzt, daher passt hier jetzt der Wert in der Software nicht. Da der resultierende Wert unter 1 kOhm liegt, ist auch die berechnete Temperatur tiefer als real, das erklärt das Verhalten des PT1000. Die zu hohe Temperatur beim PT100 erklärt das allerdings nicht, hier könnte noch etwas anderes reinspielen.
Bedeutet es dann auch, dass ich meine Minis wenn 100Ohm oder 1kOhm verbaut sind nicht einfach mit dem Esp32 nachrüsten kann?
 

s.ochs

BOFH
Teammitglied
Admin
Aktuell bedeutet es, dass du entweder den 47K wieder parallel nachrüsten müsstest oder dir den Referenzwert in der Firmware änderst (TemperatureBase.cpp Zeile 499 / 504), selbst kompilierst und installierst. Machbar ist es also, aber noch nicht so komfortabel.
Ich habe gerade mal fix mit Martin durchgesprochen, ob eine ähnliche Umsetzung der Fühlertyp-Config wie beim Raspberry möglich wäre. In dem Fall könnte man die Werte dann wieder über die Config ändern.
 

Nixarbeit

Member
Das wäre evtl. für viele Nutzer die keine Lötkenntnisse oder auch nicht das Equipment haben, weil sie ein Gerät fertig gebaut bekommen haben und sich auch mit der Software so gar nicht auskennen die beste Lösung.
Das Nachrüsten vom ESP32 bekommt ja jeder hin der das Gehäuse aufschrauben kann.

Ich bin ja "oldschool" nutze alles was ich habe so weiter. Nur wenn mich die Bastelwut ( und Zeit ) mal wieder packt hätte ich evtl. mal eins mit dem ESP32 aufgebaut zum spielen. Dann löt ich mir halt einen 47k dazu. Liegen ja genug davon im Schrank.
 

s.ochs

BOFH
Teammitglied
Admin
Richtig, bisher wurde allerdings nicht danach gefragt, daher war es keine Prio. Ich kann leider nicht abschätzen, wie viele Mini V1 mit nur 1000 oder 100 Ohm im Messkanal wirklich im Umlauf sind und genutzt werden. Mini V1 wurde primär zudem selbst gebaut, demnach ist die Kombi aus eingebaut aber keine Lötkenntnisse wahrscheinlich sehr gering.
Ab Mini V2 sollte es immer die Kombi aus 47K und 1000/100 Ohm sein, deshalb haben wir uns als Standardvorgabe hierfür entschieden.
Wenn softwareseitig eine Lösung, dann muss sie einen größeren Nutzen haben als eine Handvoll Geräte lauffähig zu machen, andernfalls lohnt der Aufwand (auch in Sachen Wartung) einfach nicht. Da löte ich dann lieber persönlich den 47K an den paar Geräten nach, wer das nicht selbst kann.
 

mc309!

New member
Also meine V1 hat ebenfalls drei Kanäle mit 1000 Ohm verbaut zum Messen von PT1000. Upgrade auf ESP32 habe ich auch gemacht bisher aber bisher noch nicht „bemerkt“, dass die PT1000 nicht mehr funktionieren, da aktuell nicht benötigt.
 

MacLitze

New member
Moin!

Danke für die Antworten! War mir nicht bewußt das da was Software- bzw. Hardwaremäßig angepasst werden muss.
Da bei mir Lötkenntnis und -möglichkeiten bestehen werde ich mir einen 47k Widerstand parallel zum 1k einlöten.
Beim 100 Ohm Widerstand ändert sich ja nicht wirklich etwas wenn man dazu einen 47k parallel schaltet: 99,8 Ohm kommen da raus. Werde ich aber auch mal ausprobieren.
Mal gucken was ich da noch heraus finden kann.
 

s.ochs

BOFH
Teammitglied
Admin
Einfluss hat es beim PT100 auch, aber wie gesagt kann ich mir die 32 °C, statt 19 °C, damit auch nicht so richtig erklären. Wird der PT100 gebraucht? Über jeden PT100 Kanal fließen halt direkt mal 33 mA, dauerhaft. Wenn das Mini an einer Powerbank hängt, macht das schon was aus. Daher würde ich wenn dann eh immer direkt auf PT1000 gehen.
 
Oben Unten