Uhrzeit ist um eine Stunde zurück - Mini V2

holledauer

Member
Servus beinand,

ich hab da zwei Mini's V2 bei der die Uhrzeit seit einiger Zeit um eine Stunde zurück ist. Updates habe ich alle gemacht, aber es ändert sich nichts. Woran kann das liegen?

Eine von den zwei V2 fährt auch nicht mehr runter, die hängt irgendwie...
Muss ich mal das Imiage neu aufspielen?
 
Zuletzt bearbeitet:

s.ochs

BOFH
Vermutlich passt die eingestellte Zeitzone nicht. Log dich mal über SSH ein und versuche mal das: sudo dpkg-reconfigure tzdata
Dort mal Europa/Berlin auswählen, falls nicht schon drin.

Bei der zweiten Mini würde ich mal eine neue SD-Karte nehmen, da das Image drauf machen und testen, ob es damit runterfährt. Wenn ja, passt entweder am Image von der alten SD-Karte was nicht oder mit der SD selbst passt was nicht.
 

holledauer

Member
Mike, besorge dir zur Sicherheit noch ein paar Nanos damit du reserve hast 🤪
Ja, er paar Nanos mehr könnten nicht schaden 😂
Post automatically merged:

Vermutlich passt die eingestellte Zeitzone nicht. Log dich mal über SSH ein und versuche mal das: sudo dpkg-reconfigure tzdata
Dort mal Europa/Berlin auswählen, falls nicht schon drin.

Bei der zweiten Mini würde ich mal eine neue SD-Karte nehmen, da das Image drauf machen und testen, ob es damit runterfährt. Wenn ja, passt entweder am Image von der alten SD-Karte was nicht oder mit der SD selbst passt was nicht.
Hallo Steffen, Danke werde ich mal versuchen, hab mit SSH noch nicht gearbeitet. Muss mich mal einlesen wie das den geht :rolleyes:
Post automatically merged:

Mit putty komme ich nicht in den Raspberry, wird wohl das SSH nicht aktiviert sein. Jetzt muss ich noch "tiefer" rein :unsure:
 
Zuletzt bearbeitet:

Halbelunge

New member
@Phantomias2006 Also wenn ssh nicht aktiviert ist, einfach mal die SD-Karte in einen Rechner deiner Wahl (in deinem Falle wahrscheinlich Windows) stecken. Auf dem dort sichtbaren Laufwerk eine Datei mit dem Namen "ssh" (natürlich ohne die " ") anlegen. Es muss da nix rein, nur eine Datei mit dem Namen. Beim nächsten Boot wird dann SSH aktiviert sein. Wenn du nicht ins SSH kommst kann es ja alternativ auch daran liegen, dass dein Mini V2 nicht im Netzwerk hängt. Konntest du denn die http-Seite den Mini im Browser aufrufen?

@s.ochs Meine Zeitzone stimmte btw damals auch nicht. Ich wusste halt wie ichs fixe, da ich daheim noch ein paar mehr Pis in Betrieb habe.
Da fällt mir ein. Wenn man während einer Messung die Zeitzone ändert, so dass eine Stunde vergangen ist, sieht der Plot lustig aus. Die Werte werden halt direkt verbunden, so dass eine Konstante entsteht.
Der Plot ist finde ich verbesserungswürdig. Wenn mehr als 3 Samples kein Wert abgelegt ist, sollte der Plot die Werte nicht mehr verbinden. Würde so diesem Verhalten entgegen wirken. Hat keine hohe Prio, wäre aber ein cooles Feature.
Und da fällt mir ein: hast du einen Überblick, wie viel Platz noch auf dem Display für Anzeigen ist? Den Plot rudimentär auch auf dem Mini anzeigen zu können wäre echt mega. :D
 

holledauer

Member
Danke dür Deine Antwort. Per Browser komme ich auf die V2. Das mit der Datei werde ich dann mal machen :)
 

s.ochs

BOFH
Und da fällt mir ein: hast du einen Überblick, wie viel Platz noch auf dem Display für Anzeigen ist? Den Plot rudimentär auch auf dem Mini anzeigen zu können wäre echt mega. :D
Gedanke ist gut, hilft einem in der Realität aber leider nicht wirklich weiter. Man kann auf dem Nextion die Beschriftung (in dem Fall dann die Achsenbeschriftung) nicht beliebig klein machen. Also bleibt am Ende eine bunte Linie geringer Auflösung, die wenig Aussagekraft hat. Hinzu kommt, dass dafür etliche Daten über die Schnittstelle geschickt und verarbeitet werden müssen. Dafür ist das Nextion nur bedingt ausgelegt. Speicherbelegung ist aktuell 3,6 MB von verfügbaren 4 MB, also nicht mehr viel übrig, @a.schaefer85 hat da schon so ziemlich das Maximum rausgeholt.
 

holledauer

Member
@Phantomias2006 Also wenn ssh nicht aktiviert ist, einfach mal die SD-Karte in einen Rechner deiner Wahl (in deinem Falle wahrscheinlich Windows) stecken. Auf dem dort sichtbaren Laufwerk eine Datei mit dem Namen "ssh" (natürlich ohne die " ") anlegen. Es muss da nix rein, nur eine Datei mit dem Namen. Beim nächsten Boot wird dann SSH aktiviert sein. Wenn du nicht ins SSH kommst kann es ja alternativ auch daran liegen, dass dein Mini V2 nicht im Netzwerk hängt. Konntest du denn die http-Seite den Mini im Browser aufrufen?...
Soll das nun eine Datei "SSH.txt" ohne Text z.B. mit Notepad sein? :unsure:
 

s.ochs

BOFH
Keine Endung. Am besten nimmst du Notepad++, erstellst eine neue Datei und nennst sie beim Speichern ssh. Für die Endung wählst du "All Files (*.*)". Dann hast du eine Datei die ssh heißt und keine Endung hat.

Edit: wenn du kein Notepad++ installiert hast (ist zu empfehlen), kannst du es auch wie hier machen: Link
Aber dann nochmal kontrollieren, dass sie wirklich keine Endung hat.
 

holledauer

Member
Danke @s.ochs hab ich versucht, weiss jetzt nicht ob ich Notepade++ aber ich kann die Datei im root Verzeichnis nicht abspeichern..
"Sie können hier nicht speichern, wählen sie einen anderen Ort aus" ist die Fehlermeldung :-(
Post automatically merged:

ich lad mir jetzt mal Notepad++ runter... ggf. hilft das dann :)
Post automatically merged:

Hhhmmm, geht auch nicht mit notepad++ :mad:
Post automatically merged:

Das "new" geht bei mir nicht...
 
Zuletzt bearbeitet:

s.ochs

BOFH
Speicher die Datei doch erstmal auf dem Desktop und kopiere sie dann rüber. Was meinst du mit "new" geht nicht.

Ich habe dir im Anhang eine ssh Datei ohne Endung angehängt. Einfach das zip entpacken.
 

Anhänge

holledauer

Member
Servus Steffen, Danke hat soweit mal geklappt, aber die Zeit wird immer noch falsch angezeigt:
Current default time zone: 'Europe/Berlin'
Local time is now: Sun Nov 24 08:25:14 CET 2019.
Universal Time is now: Sun Nov 24 07:25:14 UTC 2019.

Alles o.k. hat ein wenig gedauert nach dem Neustart, bis sich die Zeit umgestellt hat :) Danke für die Hilfe
 

Halbelunge

New member
:LOL:
Ja ok das hätte man natürlich erwähnen sollen. Bei mir änderte es sich direkt. Ich habs über die raspi-config gemacht. Wenn du es anderweitig gemacht hast kann es gut sein, dass das einen Neustart braucht, damit das System die Zeit einmal neu abfragt.

Aber schön wenn es nun funktioniert :)
 
Oben Unten