Temperaturdifferenz ausgleichen

Ich habe an einem GN Behälter den Fühler außen aufgeklebt. Jetzt misst er aber ~0,6 Grad Differenz zu einem Fühler, der direkt im Wasser hängt. Kann man diese Temperaturdifferenz irgendwie ausgleichen? In den Einstellungen der GUI habe ich nichts gefunden gehabt.
 

s.ochs

BOFH
Nein, wenn dann müsste man sowas fest einprogrammieren. Aber ein konstanter Abstand ist nur die halbe Wahrheit, der gilt so gut wie immer nur an und um eine Temperatur. Man müsste schon die Differenz über einen ganzen Temperaturbereich vermessen. Und es bleibt die Frage, ob die Referenz überhaupt stimmt.

Hast du Mal parallel mit einem zweiten Fühler die Temperatur des Wassers an einer anderen Stelle im Becken gemessen? Um welche Temperatur geht es? Und wie ist das Becken wärmegedämmt, bzw. der Fühler am Becken montiert?
 

holledauer

New member
Ich habe an einem GN Behälter den Fühler außen aufgeklebt. Jetzt misst er aber ~0,6 Grad Differenz zu einem Fühler, der direkt im Wasser hängt. Kann man diese Temperaturdifferenz irgendwie ausgleichen? In den Einstellungen der GUI habe ich nichts gefunden gehabt.
Welchen Fühler hast Du denn angeklebt? Es gibt spezielle Fühler, die für die Monatage an GN-Behältern geeignet sind und nur so 0,2 K Abweichung machen, was absolut nix ausmacht... Einen Standrad-Fühler "in Metall" kannst für diese Messung vergessen. Wir benutzen für solche Aufgaben diesen Sensor hier: https://www.reichelt.de/ntc-thermistor-100-kohm-0-2-ntc-100k-0-2-p151256.html?GROUPID=6672&SEARCH=NTC+100k+0%2C1&&r=1
 
Nein, wenn dann müsste man sowas fest einprogrammieren. Aber ein konstanter Abstand ist nur die halbe Wahrheit, der gilt so gut wie immer nur an und um eine Temperatur. Man müsste schon die Differenz über einen ganzen Temperaturbereich vermessen. Und es bleibt die Frage, ob die Referenz überhaupt stimmt.

Hast du Mal parallel mit einem zweiten Fühler die Temperatur des Wassers an einer anderen Stelle im Becken gemessen? Um welche Temperatur geht es? Und wie ist das Becken wärmegedämmt, bzw. der Fühler am Becken montiert?
Ja, hatte parallel mit zwei anderen Fantast Fühlern gemessen. Ging bei der Messung um 45,0 bzw. 45,6 Grad. Ich kann auch nochmal in höheren Bereichen versuchen.

Das Becken ist mit Bitummatten umklebt, ebenso der Fühler, der mit Wärmeleitkleber auf Höhe 1/3 aufgeklebt ist. Eigentlich soll das Becken in einer KangaBox stehen. Die hatte ich zur Messung aber oben geöffnet, um den Fantast Fühler einzuhängen. Meinst du ich soll die Messung nochmal geschlossen wiederholen?

Welchen Fühler hast Du denn angeklebt? Es gibt spezielle Fühler, die für die Monatage an GN-Behältern geeignet sind und nur so 0,2 K Abweichung machen, was absolut nix ausmacht... Einen Standrad-Fühler "in Metall" kannst für diese Messung vergessen. Wir benutzen für solche Aufgaben diesen Sensor hier: https://www.reichelt.de/ntc-thermistor-100-kohm-0-2-ntc-100k-0-2-p151256.html?GROUPID=6672&SEARCH=NTC+100k+0%2C1&&r=1
Den zitierten Fühler habe ich auch genommen (auf meiner Bestellung steht: "NTC Thermistor, 100 KOhm, 0,2 % - 1,40€").
 

s.ochs

BOFH
Ging bei der Messung um 45,0 bzw. 45,6 Grad. Ich kann auch nochmal in höheren Bereichen versuchen.
Die Fantast waren beide bei 45,6 °C?

Die hatte ich zur Messung aber oben geöffnet, um den Fantast Fühler einzuhängen. Meinst du ich soll die Messung nochmal geschlossen wiederholen?
Bei 46 °C sollte der offene Deckel nicht so viel ausmachen. Zumal du ja den Behälter mit Bitume beklebt hast, also eigentlich schon gut vorgegangen bist.

Den zitierten Fühler habe ich auch genommen (auf meiner Bestellung steht: "NTC Thermistor, 100 KOhm, 0,2 % - 1,40€").
Sollte passen.

Mach mal noch eine Messung bei 60 °C und lass die Temperatur aber mal für mehrere Minuten konstant. Sodass sich alles ausgleichen kann, dann messen. Hast du neben den Fantast noch einen anderen Fühlertyp da, den man ins Wasser halten kann?
 

holledauer

New member
Hattest Du die Temperatur bereits ausgeregelt, also z. B. auf 45 Grad eingestellt und schon eine Weile laufen lassen?
Beim Aufheizen wirst Du nie ganz gleich Temperaturen haben, da die Reaktionszeit der einzelnen Sensoren unterschiedlich ist. Schalt den PID ein und regle auf 55 Grad aus oder so und schau dann mal nach ein paar Minuten wie die Temperaturen sind. Letztlich ist ja nur die Endtemperatur für das SV Ergebnis entscheidend, denn beim Aufheizen spielen selbst ein paar Grad Differenz keine Rolle.
 
Die Fantast waren beide bei 45,6 °C?


Bei 46 °C sollte der offene Deckel nicht so viel ausmachen. Zumal du ja den Behälter mit Bitume beklebt hast, also eigentlich schon gut vorgegangen bist.


Sollte passen.

Mach mal noch eine Messung bei 60 °C und lass die Temperatur aber mal für mehrere Minuten konstant. Sodass sich alles ausgleichen kann, dann messen. Hast du neben den Fantast noch einen anderen Fühlertyp da, den man ins Wasser halten kann?
Habe leider keine anderen Fühlertypen, außer Fantast.

Habe dann zwei Plots gemacht.

Der lila ist der angeklebte Fühler.
Der rote ist in der Mitte des Beckens.
Der blaue ist im Wasser, wo sich der angeklebte Fühler befindet.

Einmal mit 45 Grad als Zieltemperatur (Differenz ist ~0,5 Grad):

45_Grad.png

Und mit 66 Grad als Zieltemperatur (Differenz ist ~0,9 Grad):

66_Grad.png
 
Dachte ich versuch es nochmal mit Inhalt. Habe ein Hähnchen drin mit Zieltemperatur 70 Grad:

70_grad.png

Unterschied ist aber auch wieder so ~0,5 bis 0,6 Grad (der Fühler der eingehängt ist, zeigt etwas mehr an), nach ~40 Minuten.
 

theo100

New member
Vielleicht nicht die schönste Lösung, aber am pragmatischsten, wenn die Differenz immer gleich ist, warum dann nicht den Setpoint ändern. Also in dem Fall um 0,5 Grad reduzieren? Oder einfach ignorieren, was sind schon 0,5 Grad.
 

s.ochs

BOFH
Oder einfach ignorieren, was sind schon 0,5 Grad.
Bei Onsen Ei spielen 0,5 °C schon eine Rolle, ansonsten gebe ich dir aber Recht. Wenn die Differenz weitestgehend konstant ist, würde ich den Offset einfach manuell mit der Sollvorgabe verrechnen. Das geht am schnellsten und einfachsten. Und ist am wenigsten fehleranfällig.
Post automatically merged:

Bei einem Fantast Fühler kann ich kein Datenblatt finden. Da kann es gut sein, dass die Fühler sogar 0.5 - 1 °C Toleranz haben.
Ohne Datenblatt natürlich schwierig zu beurteilen, die NTC-Fühler sind aber im Grunde alle gleich, nur die Widerstandskennlinie unterscheidet sich. Messabweichungen kommen bei NTC zum einen aus der Analog-Digital-Wandlung, da wird hardwareseitig bei den WLANThermos aber schon darauf geachtet, dass dieser, in den üblichen Temperaturbereichen, kleiner als 0,1 °C ist. Die andere Quelle für Abweichnungen kommt aus der approximierten Widerstandskennlinie aus den Kennwerten. Da der NTC nicht wirklich komplett linear (logarithmiert) ist, kommt es auch bei der Umrechnung der Widerstände in Temperaturen zu Abweichungen. Die fallen über den kompletten Messbereich unterschiedlich aus. Hier einzusehen. Die Abweichungen liegen im Bereich von 0,1 - 0,3 °C.

Ein Teil der Abweichung kann also durch die unterschiedlichen NTC-Fühler kommen. Der andere Teil kommt vermutlich durch Wärmeleitung am Behältergehäuse, sodass der angekebte 100K nicht ganz die Temperatur vom Wasser abbekommt.
 
Zuletzt bearbeitet:

DerBurgermeister

New member
Im Datenblatt bei Reichelt gibt es aber schon Fühler mit unterschiedlichen Toleranzen die von ± 0,1 °C bis ± 1 ° C gehen. Und Reichelt gibt nicht an, welcher Typ es ist. Außerdem steht auf der Produktbeschreibung einmal Toleranz-Klasse: ± 0,2°C für 0 … 70°C und rechts Toleranz ± 0,2 % also einmal °C und einmal %. Und wenn dann noch einer nach unten und einer nach oben bis an die Grenze abweicht, dann kommen bei ± 0,2°C gleich mal 0,4°C zusammen.
 
Oben Unten