• Cyber Weekend Special

    Erhalte 10% Rabatt auf deine in unserem WLANThermo Shop im Zeitraum vom 27.11. - 30.11.2020 bestellten Artikel, durch die Eingabe des Rabatt-Codes CYBER2020 im Checkout-Bereich.

    Cyber Weekend Special

Nano im Regen - Display tot und Fühler off

Hendrikj

New member
Hi zusammen,

war 3 Tagen am smoken als unerwarteter Regen aufkam und ich soschnell nicht aus dem Büro zum Nano gekommen bin.

Ende vom Lied der Nano Display ist dunkel und alle Fühler werden als Off angezeigt. Per web interface komme ich noch ganz normal auf den Nano und Laden kann ich ihn auch noch !

habt ihr eine Idee ? Ist der Nano noch zu retten ?
 

Anhänge

  • 42F9A444-DCAC-4683-B73D-9FD846095632.png
    42F9A444-DCAC-4683-B73D-9FD846095632.png
    451.3 KB · Aufrufe: 11

s.ochs

BOFH
Teammitglied
Lass es mal 2-3 Tage trocknen. ADC und OLED hängen beide am selben Datenbus, wenn eins von beiden beinträchtigt ist, könnte es so das andere mit beinflussen.
 

DerPapa

Der mit dem Thermo tanzt
Teammitglied
Was beim Smartphone gut ist, kann bei der nano nicht so schlecht sein. In einen Beutel mit etwas Reis legen. Zieht Feuchtigkei heraus.
P.S: Kein Müller Milchreis!!
 

a.schaefer85

Entwickler
Hmmm, der letzte der mich geärgert hat hat jetzt einen Pikatchu als Avatar.... 🤪😂
Ich ärgere dich seit Jahren und das auch noch mit Recht 😜
Den Pikatchu hast du mal wieder volltrunken hochgeladen und ich finde den ganz toll 😊


Das ist leider ein Märchen. Wenn Reis hygroskopisch wäre, würde er in der Packung schon matschig werden. Bin früher auch drauf reingefallen.
Armin lockt damit Chinesen an die das reparieren. 😅
 

panik666

New member
Hi zusammen

Ich muss mich hier kurz mal anhängen und nachfragen ob die Reis-Diät Verbesserung gebracht hat. Leider hat es meinen Nano V1+ Pro auch der Regen erwischt und ich hab das selbe Fehlerbild. Alle Fühler auf OFF und Display tot. :cry::cry:

mfg Markus
 

s.ochs

BOFH
Teammitglied
Schraube es mal auf, klapp die Gehäusehälften auseinander und lasse es mal 2-3 Tagen auf der Fensterbank trocknen. Am besten auch immer erst trocknen lassen, bevor man es wieder anschaltet, also wenn sichtlich Wasser rein gelaufen ist.
Deine Beschreibung deutet auf einen Fehler im I²C-Datenbus hin. Kann sein, dass da unter einer Komponente Feuchtigkeit "steht" und deshalb der Datenbus lahm gelegt ist.
 

panik666

New member
Hi, nach 3 Tagen trocknen auf der Fensterbank hat sich leider am Fehlerbild nichts geändert (Display aus und alle Kanäle auf OFF).

Hat noch wer eine Idee was ich tun kann um ihn wieder zum Leben zu erwecken?
Gibt es eigentlich eine Möglichkeit für einen Reset auf Werkseinstellung? /configreset hab ich schon gefunden aber das resetet ja nur die Config und nicht alles.

Bzw hat irgendwer Lust da Mal drüber zu sehen und ihn möglicherweise zu reparieren? Wenn nichts mehr hilft muss ich mir einen neuen Bestellen.

Mfg Markus
 

s.ochs

BOFH
Teammitglied
Du könntest dir mal an einem Seriellen Monitor ansehen, ob sich auf dem ESP noch was tut. Ansonsten kannst du auch mit dem esptool den Speicher einmal komplett leeren und dann die Firmware neu aufspielen. Wenn du da Hilfe brauchst, sag Bescheid. Ansonsten kann ich mir dein Nano auch gern mal ansehen. Schreibe mich einfach kurz per PN an und dann schick ich dir die Adresse.
 

panik666

New member
Hi, ich kann mich über putty mit dem nano verbinden und auch das startlog mitlesen allerdings reagiert er auf die eingabe von AT mit
AT
[INFO] You entered: >AT<
Unkwown command

entweder mach ich da was falsch oder das ESP ist tatsächlich hinüber

anbei noch das komplette log vom Nano (ich hoffe ich hab alle wifi keys rausgeschnitten :oops:)
AT
[INFO] You entered: >AT<
Unkwown command
[INFO] Standby
Fatal exception 3(LoadStoreErrorCause):
epc1=0x4010010e, epc2=0x00000000, epc3=0x00000000, excvaddr=0x400718a1, depc=0x00000000

Exception (3):
epc1=0x4010010e epc2=0x00000000 epc3=0x00000000 excvaddr=0x400718a1 depc=0x00000000

ctx: cont
sp: 3fff3450 end: 3fff36f0 offset: 01a0

>>>stack>>>
3fff35f0: 0000003c 02000000 00000004 0000007d
3fff3600: 3fff25dc 0000fb26 0000fb26 4010020c
3fff3610: 3fff1bbc 3fff733c 3fff18a4 4010068c
3fff3620: 0000001e 00000001 3ffe8835 40225714
3fff3630: 3fff25dc 00000006 3ffe84e6 40208ee4
3fff3640: 3fffdad0 00000007 3fff1b7c 40227030
3fff3650: 00000000 3fff2604 3fff2604 4021e2ba
3fff3660: 3ffe84e0 00000006 3fff2604 4021e49d
3fff3670: 3fffdad0 3fff2604 00000001 4020af9c
3fff3680: 3fffdad0 3fff2604 00000001 40214286
3fff3690: 3fff1cd0 3fff1db8 3fff0b28 40215198
3fff36a0: 3fffdad0 00000000 3fff1ee8 4020af16
3fff36b0: 00000000 00000001 00006d2f 3fff1be0
3fff36c0: 00000000 00000000 00000001 3fff26c0
3fff36d0: 3fffdad0 00000000 3fff26ba 40225938
3fff36e0: feefeffe feefeffe 3fff26d0 40100718
<<<stack<<<

ets Jan 8 2013,rst cause:2, boot mode:(3,7)

load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d
v3de0c112
~ld


[INFO] Exception
SDK version:1.5.3(aec24ac9)
[INFO] FV: v1.0.6
[INFO] SKETCH: 0x01 (403K)
[INFO] EEPROM: 0xFB (2816B)
[INFO] SPIFFS: 0xCB (192K)
[INFO] FS: /index.html.gz : 58.97KB
[INFO] FS: /url.json : 157B
[INFO] FS: /nano.ttf : 13.44KB
[INFO] Total: 169.38KB Used: 74.03KB
[INFO] rEE: [{"SSID":"unifi_IoT","PASS":"***************"},{"SSID":"Carport","PASS":"***************"},{"SSID":"Xiaomi-garage","PASS":"***************"},{"SSID":"Xiaomi-garage_EXT","PASS":"***************"}]
[INFO] l: /wifi.json
[INFO] rEE: {"ch":8,"host":"NANO-29bace","ap":"NANO-AP","lang":"de","hwversion":1,"update":0,"getupd":"false","autoupd":true,"batmax":4180,"batmin":3550,"god":0,"typk":false,"pitsup":false,"batfull":-1,"pass":"admin","damper":false}
[INFO] l: /system.json
[INFO] rEE: {"temp_unit":"C","tname":["Kanal 1","Kanal 2","Kanal 3","Kanal 4","Kanal 5","Kanal 6","Kanal 7","Kanal 8"],"ttyp":[0,0,0,0,0,0,0,0],"tmin":[10.0,10.0,10.0,10.0,10.0,10.0,10.0,10.0],"tmax":[35.0,35.0,35.0,35.0,35.0,35.0,35.0,35.0],"talarm":[0,0,0,0,0,0,0,0],"tcolor":["#0C4C88","#22B14C","#EF562D","#FFC100","#A349A4","#804000","#5587A2","#5C7148"]}
[INFO] l: /channel.json
[INFO] rEE: {"PMQhost":"192.168.2.1","PMQport":1883,"PMQuser":"","PMQpass":"","PMQqos":0,"PMQon":false,"PMQint":30,"CLon":false,"CLtoken":"29bace5f0ee08d7a","CLint":30}
[INFO] l: /thing.json
[INFO] rEE: {"pm":[{"ch":0,"pid":0,"set":50.0,"act":0,"res":true,"val":0.00}],"pid":[{"name":"SSR SousVide","id":0,"aktor":0,"Kp":104.0,"Ki":0.200,"Kd":0.0,"DCmin":0.0,"DCmax":100.0,"jp":100,"ol":0},{"name":"TITAN 50x50","id":1,"aktor":1,"Kp":3.8,"Ki":0.010,"Kd":128.0,"DCmin":25.0,"DCmax":100.0,"jp":70,"ol":0},{"name":"Kamado 50x50","id":2,"aktor":1,"Kp":7.0,"Ki":0.019,"Kd":630.0,"DCmin":25.0,"DCmax":100.0,"jp":70,"ol":0}]}
[INFO] l: /pit.json
[INFO] rEE: {"onP":0,"tokP":"","idP":"","rptP":1,"svcP":0}
[INFO] l: /push.json
[INFO] l: /url.json
[INFO] M24C02: No
[INFO] Standby
OFF: 0, 0, 0
OFF: 0, 0, 0
del if0
bcn 0
del if1
usl

ets Jan 8 2013,rst cause:2, boot mode:(3,7)

load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d
v3de0c112
~ld


[INFO] Software/System restart
SDK version:1.5.3(aec24ac9)
[INFO] FV: v1.0.6
[INFO] SKETCH: 0x01 (403K)
[INFO] EEPROM: 0xFB (2816B)
[INFO] SPIFFS: 0xCB (192K)
[INFO] FS: /index.html.gz : 58.97KB
[INFO] FS: /url.json : 157B
[INFO] FS: /nano.ttf : 13.44KB
[INFO] Total: 169.38KB Used: 74.03KB
[INFO] rEE: [{"SSID":"unifi_IoT","PASS":"***************"},{"SSID":"Carport","PASS":"***************"},{"SSID":"Xiaomi-garage","PASS":"***************"},{"SSID":"Xiaomi-garage_EXT","PASS":"***************"}]
[INFO] l: /wifi.json
[INFO] rEE: {"ch":8,"host":"NANO-29bace","ap":"NANO-AP","lang":"de","hwversion":1,"update":0,"getupd":"false","autoupd":true,"batmax":4180,"batmin":3550,"god":0,"typk":false,"pitsup":false,"batfull":-1,"pass":"admin","damper":false}
[INFO] l: /system.json
[INFO] rEE: {"temp_unit":"C","tname":["Kanal 1","Kanal 2","Kanal 3","Kanal 4","Kanal 5","Kanal 6","Kanal 7","Kanal 8"],"ttyp":[0,0,0,0,0,0,0,0],"tmin":[10.0,10.0,10.0,10.0,10.0,10.0,10.0,10.0],"tmax":[35.0,35.0,35.0,35.0,35.0,35.0,35.0,35.0],"talarm":[0,0,0,0,0,0,0,0],"tcolor":["#0C4C88","#22B14C","#EF562D","#FFC100","#A349A4","#804000","#5587A2","#5C7148"]}
[INFO] l: /channel.json
[INFO] rEE: {"PMQhost":"192.168.2.1","PMQport":1883,"PMQuser":"","PMQpass":"","PMQqos":0,"PMQon":false,"PMQint":30,"CLon":false,"CLtoken":"29bace5f0ee08d7a","CLint":30}
[INFO] l: /thing.json
[INFO] rEE: {"pm":[{"ch":0,"pid":0,"set":50.0,"act":0,"res":true,"val":0.00}],"pid":[{"name":"SSR SousVide","id":0,"aktor":0,"Kp":104.0,"Ki":0.200,"Kd":0.0,"DCmin":0.0,"DCmax":100.0,"jp":100,"ol":0},{"name":"TITAN 50x50","id":1,"aktor":1,"Kp":3.8,"Ki":0.010,"Kd":128.0,"DCmin":25.0,"DCmax":100.0,"jp":70,"ol":0},{"name":"Kamado 50x50","id":2,"aktor":1,"Kp":7.0,"Ki":0.019,"Kd":630.0,"DCmin":25.0,"DCmax":100.0,"jp":70,"ol":0}]}
[INFO] l: /pit.json
[INFO] rEE: {"onP":0,"tokP":"","idP":"","rptP":1,"svcP":0}
[INFO] l: /push.json
[INFO] l: /url.json
[INFO] M24C02: No
[INFO] Hostname: NANO-29bace
bcn 0
del if1
add if1
dhcp server start:(ip:192.168.66.1,mask:255.255.255.0,gw:192.168.66.1)
bcn 100
[INFO] AP: NANO-AP
[INFO] AP IP: 192.168.66.1
[INFO] HTTP server started
[INFO] MAX1161x: No
OFF: 0, 15, 0
OFF: 0, 14, 0
wifi: multi
wifi: unifi_IoT
f r0, scandone

state: 0 -> 2 (b0)
state: 2 -> 3 (0)
state: 3 -> 5 (10)
add 0
aid 10
cnt

connected with unifi_IoT, channel 11
dhcp client start...
ip:192.168.8.15,mask:255.255.255.0,gw:192.168.8.1

[INFO] STA: unifi_IoT
[INFO] IP: 192.168.8.15
[INFO] mDNS startedbcn 0
del if1
pm open,type:2 0
mode : sta(3c:71:bf:29:ba:ce)
[INFO] wifi: STA

AT
[INFO] You entered: >AT<
Unkwown command
[

Vielleicht kannst du da noch mal drüberschaun
 

s.ochs

BOFH
Teammitglied
Also da scheint irgendwas am I²C-Bus defekt zu sein. Am Bus hängen das OLED und der ADC, der die Fühler ausliest. Kann sein, dass eine Komponente einen Schaden hat und deshalb der Bus komplett ausfällt. Der ESP selbst läuft normal, das Webinterface kannst du ja auch aufrufen. Ein Zurücksetzen der Software würde da nichts ändern. Sieht nach einem Hardwarefehler aus. Wenn ich's mir mal ansehen soll, schreib mir kurz per PN.
 
Oben Unten