Minustemperaturen

DeLorean

Member
Moin !

Ich wollte heute mit meinem Nano (mini v1 habe ich nicht getestet) mal die Temperatur von selbst hergestellter Eiscreme messen.

Verwendet habe ich einen iGrill 2 Doppeltemperaturfühler... auf dem Display sah ich nach dem einstechen ins gefrorene Eis zunächst noch die Temperatur runtergehen aber so (ich glaube) bei -7/-8 Grad war die Anzeige weg also für Kanal 1 stand off, Kanal 7 wird aber normal angezeigt.

Auch in der Brwoseranzeige wird mir der Kanal nicht angezeigt.

Liegt das nun am Fühler oder ist das Nano nicht in der Lage so niedrige Temperaturen (müsste im Bereich -18 bis -20 liegen) anzuzeigen ?
 

EinBjoern

Entwickler
Funktioniert nicht weil ganz niedrige Temperaturen sich irgendwann nicht von einem offenen Anschluss unterscheiden lassen.
Die Nano funktioniert unter -10 nicht mehr, die klassischen nehmen einen festen ADC Wert an, damit ist die Grenze Sensorabhängig, beim iGrill2 wären das dann unter -50 Grad, theoretisch. Praktisch wohl eher weniger.
 

DeLorean

Member
Das heisst das funktioniert beim Nano nicht weil es in der Software fest eingestellt dass es nur bis -10 Grad anzeigt ?

Lässt sich das (ggf. von mir selbst) ändern ?
 

s.ochs

BOFH
Teammitglied
Theoretisch ja, du müsstest dir die Arduino-IDE installieren, den ESP-Core einrichten, alle Libs installieren und das Nano-Projekt von GitHub laden. In der c_temp.h muss diese Zeile geändert werden:

return (erg>-10)?erg:INACTIVEVALUE;

Wenn du da weiter runter gehst als -10 werden auch tieferen Temperaturen ausgegeben, sofern am ADC noch was gemessen wird. Irgendwann kommst dann ins Messrauchen.

[Edit]: hast eine PN von mir
 
Zuletzt bearbeitet:
Oben Unten