Maverick ET-75 Roti Thermometer

butcherson

New member
Hallo zusammen, ich möchte gerne wissen ob ich irgendwie von meinem Maverick ET-75 das Signal abgreifen kann.
Muss ich dafür ein Hardwareupdate machen? Welche Teile benötige ich? die Antenne und das 433MHz Modul, oder
sonst noch etwas? oder geht es beim Mini V1 garnicht?

viele Grüße
Markus
 

s.ochs

BOFH
Teammitglied
Hi Markus,

also das Auslesen eines Funksenders funktioniert für die Maverick-Modelle ET-732 und ET-733. Ob es auch beim ET-75 klappt, kann ich leider nicht beantworten. Bin nicht sicher, ob Maverick da das selbe Übertragungsprotokoll benutzt. Bei den neueren Modellen XR-x z. B. wird von Maverick ein anderes Protokoll benutzt, sodass sie nicht ausgelesen werden. Ansonsten reicht hardwareseitig aber das Funkmodul und die Antenne. Wenn sich keiner findet, der dir die Nutzung eines ET-75 bestätigen kann, müsstest du es eventuell einfach versuchen und dann am besten berichten.

Gruß
Steffen
 

butcherson

New member
Danke Steffen,
ich habe die Teile bestellt. wo müssen die angelötet/angesteckt werden?

vielen Dank und viele Grüße
Markus
 

s.ochs

BOFH
Teammitglied
Wird angelötet. Wenn du dir deine Platine ansiehst, siehst du eigentlich direkt, wo es hingehört:

miniplatinefunkmodul.png

Und in der Software musst du es in den Einstellungen aktivieren.

Gruß
Steffen
 

binoffline

Stylist
Die Antenne kommt ganz rechts hin, da wo drunter ANT steht. Ist wenn du die Teile vor dir hast ist es ganz einfach und selbsterklärend ;)
Wichtig ist nur das du das Modul so verlötest das dir Seite mit den Bauteilen zur Außenseite der Mini Platine zeigt.
 

s.ochs

BOFH
Teammitglied
Einfach auf die Beschriftung auf der Mini-Platine und der Funk-Modul-Platine achten, dann kann nichts schief gehen.

So sieht es beim Mini V2 aus. Beim Mini V1 ist die Position identisch, nur das Drumherum sieht anders aus:

IMG_20200423_121043163.jpg
 

Kunstflieger

New member
Ich habe ebenfalls einen 433Mhz Empfänger mit Antenne bei mir verbaut. Allerdings bekomme ich auch nichts angezeigt. Gibt es irgendwie die Möglichkeit, evtl auch über ssh, die empfangenen Daten anzuzeigen? Mit einer 433Mhz Fernbedienung könnte ich dann testen, ob überhaupt ein RF Signal empfangen wird.
 

Kunstflieger

New member
Ich habe jetzt noch WiringPi und RFSniffer auf dem Raspberry installiert. Dabei konnte ich feststellen, dass zwar Signale empfangen werden. Diese aber nur sehr schlecht aufgenommen werden. Ich hatte eine 433Mhz Fernbedienung genommen und eine Steckdose geschaltet. Die Steckdose schaltete immer, aber der Code wurde nur sehr selten vom Raspberry erkannt. Erst nach dem ca 15-30 Signal wurde es mal erkannt.
Kann es evtl damit zusammenhängen, dass der Pi eine CPU Auslastung von über 90% hat? Das hat er bei mir schon immer, gleich nach dem Neustart.
 

s.ochs

BOFH
Teammitglied
In welchem Gehäuse sitzt dein Mini? Wird gar nix am Pi erkannt, oder wird eventuell so viel ringsrum erkannt, dass nur das "richtig" Signal nicht erkannt wird?
 

Kunstflieger

New member
Ich verwende ein normales 3D Druckgehäuse aus Kunststoff. Es wird sonst kein anderes Signal erkannt, als das der Fernbedienung. Und das Signal ist dann auch richtig. Mir kommt es eher so vor, als ob der RPI überlastet ist und nicht hinterher kommt das Signal zu decodieren. Ist das mit der hohen CPU Auslastung normal? Hatte deswegen auch schonmal den RPI neu aufgesetzt. Hat aber nichts gebracht.
 

Phantomias2006

Entwickler
Im Prinzip hat Björn das decodieren des Maverick-Signals damals entkoppelt vom Projekt. Hier der Link zu Github:

Wenn ich mich nicht irre kannst du die py auch manuell und auch im debug Mode unabhängig von der ThermoSW laufen lassen. Vl hilf dir das.
BG
 

Kunstflieger

New member
Ich habe mal den Maverick-Empfänger in den configs ausgeschaltet um zu prüfen, ob die CPU-Auslastung runtergeht, aber sie bewegt sich trotzdem im Bereich von 90%.
Wie ist bei euch die CPU Auslastung? Habt ihr ähnliche Werte? - Ein erneutes Aufspielen des Images auf die SD Karte hat keine Besserung gebracht.
 

s.ochs

BOFH
Teammitglied
Auslastung von 50-70% beim Zero ist aber nicht unüblich. 90% ist schon arg hoch.
 
Oben Unten