[gelöst]: Nano V1+ Sollwert wird nicht erreicht

flow

New member
Guten Morgen!

Erst mal ein Großes Dankeschön an alle Entwickler für alle Wlanthermos die auf dem Markt sind und auch vor allem Danke an ALLE für den tollen Support den ihr liefert!
Hatte gestern endlich mal zeit, mein neues Nano V1+ zu testen, was auch super und vor allem einfach funktioniert. PID wurde mit einmaligem autotune erstellt.
Aufgefallen ist mir bei meinem System, dass sich die Temperatur ohne großartige Eingriffe des Lüfters sehr genau regeln lässt, jedoch die eingegebene Solltemperatur (110°C ) nie erreicht wird. Für mich sieht es so aus, als würde er um 104°C regeln.

Hat hier jemand eventuell eine Idee an was das liegen könnte?

Wäre nur reines Interesse, da es den 10kg PP (und auch mir) egal ist ob 104°C oder 110°C.
Ich häng noch meine aktuellen Settings und den Cloud-link dazu, ist derzeit noch live. Am derzeitigen Standort ist nur Inet über Hotspot möglich, der leider nächtens mal versagt hat, wie man am plot erkennen kann :(


Meine Settings:

{"device":{"device":"nano","serial":"2a6967","item":"n2E02p519a0","hw_version":"v2","sw_version":"v1.0.6","api_version":"1","language":"de"},"system":{"time":"1567844477","unit":"C","ap":"NANO-AP","host":"NANO-2a6967","language":"de","version":"v1.0.6","getupdate":"false","autoupd":true,"hwversion":"V1+","god":0},"hardware":["V1","V1+"],"api":{"version":"1"},"sensors":["1000K/Maverick","Fantast-Neu","Fantast","100K/iGrill2","ET-73","Perfektion","50K","Inkbird","100K6A1B","Weber_6743","Santos","5K3A1B"],"pid":[{"name":"SSR SousVide","id":0,"aktor":0,"Kp":104.00,"Ki":0.20,"Kd":0.00,"DCmmin":0.00,"DCmmax":100.00,"opl":0,"tune":0,"jp":100},{"name":"TITAN 50x50","id":1,"aktor":1,"Kp":3.30,"Ki":0.00,"Kd":150.00,"DCmmin":25.00,"DCmmax":100.00,"opl":1,"tune":0,"jp":70},{"name":"Kamado 50x50","id":2,"aktor":1,"Kp":7.00,"Ki":0.02,"Kd":630.00,"DCmmin":25.00,"DCmmax":100.00,"opl":0,"tune":0,"jp":70}],"aktor":["SSR","FAN","SERVO"],"iot": usw...
Falls wer eine Idee hat wäre ich dankbar für eine Erklärung :)
Lg sachsi
 

s.ochs

BOFH
Hi Sachsi,

setze mal bitte Ki auf 0,01 im PID-Profil. Ich vermute mal du nutzt das TITAN50x50. Den Autotune hättest dir vermutlich sparen können, dabei wurde lediglich der I-Anteil auf 0 gesetzt. Ich vermute mal du nutzt dein Nano an einem Grill mit viel Speichermasse? Der Autotune hat dann einen zu großen I-Anteil im System erkannt und den vom PID absenkt, nur ohne Ki kann die Solltemperatur nicht gehalten werden. P- und D-Anteil reagieren nur auf Abweichungen. Lediglich der I-Anteil funktioniert auch bei Abweichung 0 zu Soll. Deshalb hält sich der Regler selbst immer etwas auf Abstand zum Sollwert. Auch mal interessant zu sehen :D
Kannst das TITAN50x50 theoretisch auch wieder auf seine alten Werte zurücksetzen, mal abgesehen vom Ki, bist du da aktuell eh nicht weit weg von: Kp = 3,8; Ki = 0,01; Kd = 128. Damit kommst du vermutlich gut hin. Da dein System aber in der Tat sehr gut auf den Aktor zu reagieren scheint, kannst auch mal das Kamado50x50 mit dem höheren Kp ausprobieren, senk Kd aber ab auf 150.

Und freut mich zu hören, dass dir dein Nano gefällt ;)
Lass dir dein PP schmecken!
Steffen

P.S. 10kg PP :unsure:, muss eine große Sau gewesen sein.
Post automatically merged:

Ich habe zur Dokumentation mal ein Screenshot vom aktuellen Regelverhalten ohne I-Anteil gemacht.

U1.png
 

flow

New member
Danke für die schnelle antwort, werd ich dann gleich ausprobieren!

Du hast natürlich recht, benützt wird ein Titan 50X50 und der Griller lässt sich am besten als "Ugly Kanalrohr" in den üblichen UDS - Maßen mit 6mm Wandstärke und altem Windkessel als Deckel bezeichnen:)

Leider sind die 10 kg PP auf 3 Stück aufgeteilt, ansonsten würde ich schon zum züchten anfangen :)

LG Sachsi
 

s.ochs

BOFH
Gern. Aktuell würde ich einfach etwas Ki einfügen. Regler sollte sich dann selbst an Soll annähern. Sollte das System dann leicht schwingen, nimmst Ki etwas runter, aber eben nicht 0. Für den nächsten Lauf würde ich dann mal das Kamado-Profil testen, mit etwas mehr Dynamik.
Post automatically merged:

"Ugly Kanalrohr" in den üblichen UDS - Maßen mit 6mm Wandstärke und altem Windkessel als Deckel bezeichnen
Jetzt musst du uns aber auch ein Foto von machen :ROFLMAO:
 

flow

New member
Ki wurde jetzt mal geändert, leider war ich etwas zu geizig mit den Kohlen, hab nachlegen müssen. Wenn sich alles stabilisiert hat, kann ich mehr zu den Änderungen sagen, aber schon mal danke für den Input!

Zur Tonne, Die Betonung liegt noch sehr auf „ugly“, Verschönerungen gibts erst wenn ich mich zum Fertigschweissen aufgerafft habe und alles eingeregelt ist;-)

2 Ebenen, WaMa- Trommel als Kohlekorb, jeweils ein 1 Zoll-Kugelhahn als Zu-/Abluft, weil das Ding nur mit Nano/Mini betrieben wird. Dazwischen noch eine Paellapfanne als Schild und heute ausnahmsweise eine Saftschale.
 

Anhänge

s.ochs

BOFH
Macht einen stabilen Eindruck, bringt aber auch ein bisschen was auf die Waage :)
Post automatically merged:

Falls du das gerade noch schnell siehst: Schalt den Pitmaster einmal kurz auf OFF und dann wieder an, oder starte dein Nano kurz am Schalter neu!
Post automatically merged:

Da habe ich nicht dran gedacht, aber durch die 12h Lauf mit konstanter Abweichung zu Soll, ist die I-Summe komplett "vollgelaufen". Wenn da jetzt ein Ki dazu kommt, läuft der Pitmaster durchweg auf 100% bzw. dauert es etwas, bis der Pitmaster runterregelt. Durch den Neustart des Pitmasters, wird die Summe auf 0 gesetzt.
 

flow

New member
Danke, Hab mich schon gewundert dass der noch auf 100% läuft, jetzt schauts mal gut aus soweit.

Derzeit bin ich auf knappe 125 Kg, mit Scharnier und vielleicht einem permanenten Hitzeschild werden wohl 140 werden :)
Da meine erste Tonne durchgerostet ist, wollte ich etwas stabiler bauen.
Lg sachsi
 

flow

New member
Hab jetzt wie gesagt die Ki auf 0,01 erhöht, und bin nach aufmachen, kohle nachlegen etc. ohne großartige Pendler auf ziemlich genau 110°C Solltemperatur „punktgelandet“, Danke für die Hilfestellung, nächstes Mal probier ich die Kamado-Settings aus und berichte dann :)

84E0A200-A248-4D04-AA7F-1FA665E8CFBE.jpeg


Lg sachsi
 

s.ochs

BOFH
Du hast dir da ein wirklich schönes Grillgerät gebaut, lässt sich super regeln. Der massive Aufbau und die Dichtigkeit spielen da sicher eine große Rolle. Aber auch die Luftführung im Inneren. Vielleicht magst du da ja irgendwann mal noch ein Foto von einstellen.
So ist die Regelstrecke einfach sehr eindeutig und lässt sich ohne viel Optimierung leicht regeln. Einen ganz leichten Schwinger hast du noch drin, ich würde daher mal Kp um 2,0 erhöhen. Damit verschiebt sich das Verhältnis aus P-Anteil und I-Anteil, was das leichte Schwingen noch reduzieren sollte.
 

flow

New member
Fotos gibts morgen nach dem putzen, Kp hab ich gestern am ende noch erhöht, allerdings war die Gier nach Fleisch letztendlich größer um noch Änderungen festzustellen, kommt dann beim nächsten Durchlauf!
 

flow

New member
Hallo

Spät aber doch, die versprochenen fotos:
351B9790-6098-4F93-B946-EF2A46579C86.jpeg
Eigentlich nix besonderes, Lufteinlass ist ca. 3cm über dem Boden

E05D2CF6-9D6F-4C49-9F88-B748C051EDE0.jpeg047C4FF7-209D-4644-93F0-56E27181B801.jpeg
WaMaTrommel hab ich Ca. 5 cm erhöht auf eine Stahlplatte geschweisst, sodass die Luft schön von unten reinziehen kann, der ganze Dreck auf der Platte landet und die Tonne somit halbwegs sauber bleibt.
Auf das „Flachstahlkonstrukt“ am 2. Foto wird die Paellapfanne als Hitzeschild aufgelegt (wird seit einem Jahr überarbeitet, wollten so schnell wie möglich testen :) )

55D3BF58-33F9-4376-95FA-EF02864CB077.jpeg
Da der Windkessel in der Höhe wie ich ihn als Deckel haben wollte einen größeren Durchmesser als die Tonne hatte, hab ich ein Vierkantprofil 20x20 als Auflage gebogen und eingeschweisst.

Das Ganze war eigentlich alles als schnelle Lösung für einen schnellen Test ausgedacht, hat sich mittlerweile aber als ziemlich effektiv herausgestellt. Kohlekorb wird unten jedoch noch mehr aufgebohrt, beim Putzen hab ich gesehen, dass eigentlich noch genug Kohlen übriggeblieben wären, schätze die Luftlöcher waren verstopft.

Lg sachsi
 
Oben Unten