• SHOP-INFO: Nachschub für unser WLANThermo Mini V3 ist eingetroffen. Somit kann es ab dem 30.07.2021 wieder bestellt werden. Die Auslieferung der Bestellungen beginnt ab dem 06.08.2021. Wir bedanken uns herzlich für euer geduldiges Warten!

Akku / Pitmaster

Dominik

New member
Hi,

die Akkuanzeige hat drei Status: Akku, wird geladen und USB. Nur bei den beiden letzteren funktioniert der Lüfter.
Im Webinterface gibts aber nur zwei Status: Akku und wird geladen. Das Akku Symbol wird auch angezeigt wenn es voll und an USB hängt.

Nun zum Problem. Die Pitmastergeschwindigkeit wird angezeigt unabhängig davon ob der Lüfter drehen kann oder nicht. Woher weis ich über das Webinterface ob alles funktioniert?

Gruss
Dominik
 

s.ochs

BOFH
Teammitglied
Admin
Ich versteh die Frage leider nicht ganz. Der Pitmaster läuft nur, wenn eine externe Quelle angeschlossen ist, da die Stromversorgung des Pitmasters nicht über den internen Akku des Thermos läuft. In der Form der Darstellung sind wir am OLED begrenzt, aufgrund der Pixelzahl. Deshalb unterscheiden sich die Symbole etwas. Die drei Zustände sind aber richtig. Sobald eine externe Quelle angeschlossen ist, wird der Akku geladen, falls nicht schon voll. Der Akku ist in dem Zustand nicht unter Last.
Das Pitmaster-Icon dreht, sobald es einen Pitmasterwert gibt. Ein Feedback ob der Lüfter aber auch wirklich dreht, gibt es nicht. Das ist über eine 2-polige Leitung nicht wirklich umsetzbar. Ob der Lüfter wirklich funktioniert, sieht man aber recht schnell an der Temperatur im Grill.
Gruß
Steffen
 

Dominik

New member
Hi,

ich habe das Nano mit einer Powerbank betrieben. Akku voll. Lüfter dreht (30%). Angezeigt wir im Webinterface 30% und das Akku Symbol. Am Gerät wird das USB Symbol angezeigt.
Die Powerbank geht aus (bei zu wenig Last schaltet sie ab). Nun steht am Gerät das Akkusymbol und 30% und im Web das Akkusymbol und 30%. In Web somit das Gleiche wie vorher als die Powerbank noch Strom geliefert hat. Der Lüfter dreht natürlich nicht.

Wie erkenne ich aus der Ferne diesen Umstand?

Gruss
 

s.ochs

BOFH
Teammitglied
Admin
Danke, jetzt habe ich das Problem verstanden. Die Powerbank schaltet aufgrund ihrer "Smart"-Funktion ab. Zu Beginn wurde vermutlich noch der interne Akku vom Nano geladen, da war die Stromaufnahme hoch genug. Als der voll war, hat die Abschaltung zugeschlagen, da die Stromaufnahme unter die Powerbank-Grenze fiel. Um das Abschalten zu vermeiden kannst du entweder einen konstanten Verbraucher mit an die PB hängen, sofern mehrere Anschlüsse vorhanden sind, eine PB ohne Smart-Funktion nutzen, oder mal die (noch im Test befindliche) Powerbank-Wächter-Funktion vom Nano aktivieren. Hierfür musst du in den RecoveryMode wechseln (Aufruf von IPdesNano/recovery) und dort im Bereich Settings über den Import-Button das File im Anhang hochladen. Über den Restart-Button den RecoveryMode wieder verlassen. Bei aktvierter Wächter-Funktion wird die Stromaufnahme künstlich erhöht, sodass sie über der Grenze der Powerbank liegt.

Hinsichtlich Erkennung: normalerweise sollte der Pitmasterwert auf 0 % fallen, sofern die externe Quelle wegfällt. Warum das in deinem Fall nicht passiert ist, muss ich mir mal im Code genauer nachsehen. Eine Warnmeldung, dass bei aktiviertem Pitmaster die Quelle weggefallen ist, ist in Planung, wird aber erst mit dem neuen Benachrichtigungssystem umgesetzt.

Edit: hatte den Anhang vergessen
 

Anhänge

  • Settings_PbGuard.txt
    50 Bytes · Aufrufe: 7
Zuletzt bearbeitet:

Dominik

New member
Ok danke. Dann warte ich mal.
Generell ist das Problem nicht so groß wenn man a. etwas Vertrauen gefunden hat und b. mit einem Netzteil arbeitet und nicht mit einer Powerbank.
 
Oben Unten