Mein nano lässt keine updates zu und bricht ab

Stoykengesicht

New member
Hallo und guten Tag, mein nano hat mich nie nach nem Update gefragt und nun kam beim Anklicken von der nano cloud für die Temperatur Verläufe die Meldung für ein Update und wienes gemacht werden muss wenn kein gelbes Ausrufezeichen Zeichen vorhaben ist.. habe mir hier auch schon einige Sachen erlesenbund getestet, leider ohne Erfolg..
Folgende Daten gibt das nano aus

Seriennummer: 82e437
Hardwareversion: V1

Ip/settings:
{"system":{"time":"1564841704","ap":"NANO-Thermo","host":"NANO-Thermo","language":"de","unit":"C","hwalarm":false,"fastmode":false,"version":"v0.8.0","getupdate":"false","autoupd":true,"hwversion":"V1"},"sensors":["Maverick","Fantast-Neu","Fantast","iGrill2","ET-73","Perfektion","5K3A1B","MOUSER47K","100K6A1B","Weber_6743","Santos"],"pid":[{"name":"SSR SousVide","id":0,"aktor":0,"Kp":165.00,"Ki":0.59,"Kd":1000.00,"Kp_a":100.00,"Ki_a":0.08,"Kd_a":5.00,"DCmmin":0,"DCmmax":100},{"name":"TITAN 50x50","id":1,"aktor":1,"Kp":3.80,"Ki":0.01,"Kd":128.00,"Kp_a":6.20,"Ki_a":0.00,"Kd_a":5.00,"DCmmin":25,"DCmmax":100},{"name":"Kamado 50x50","id":2,"aktor":1,"Kp":7.00,"Ki":0.02,"Kd":630.00,"Kp_a":6.20,"Ki_a":0.00,"Kd_a":5.00,"DCmmin":25,"DCmmax":100}],"aktor":["SSR","FAN"],"iot":{"TSwrite":"","TShttp":"","TSuser":"","TSchID":"","TSshow8":false,"TSint":30,"TSon":false,"PMQhost":"192.168.2.1","PMQport":1883,"PMQuser":"","PMQpass":"","PMQqos":0,"PMQon":false,"PMQint":30,"TGon":1,"TGtoken":"920995476:XXXXXX8sklw_sZhNq16-2_aM9hh86M8JsBQ","TGid":"XXXXX0305","CLon":false,"CLtoken":"82e43738b12096f5","CLint":30},"hardware":["V1"],"notification":["telegram","pushover"]}

Ip/data:
{"system":{"time":"1564841791","soc":98,"charge":false,"rssi":-93,"unit":"C"},"channel":[{"number":1,"name":"Kanal 1","typ":0,"temp":999.00,"min":10.00,"max":90.00,"alarm":true,"color":"#0C4C88"},{"number":2,"name":"Kanal 2","typ":0,"temp":999.00,"min":1.00,"max":100.00,"alarm":true,"color":"#22B14C"},{"number":3,"name":"Kanal 3","typ":0,"temp":999.00,"min":10.00,"max":52.00,"alarm":true,"color":"#EF562D"},{"number":4,"name":"Kanal 4","typ":0,"temp":999.00,"min":10.00,"max":62.00,"alarm":true,"color":"#FFC100"},{"number":5,"name":"Kanal 5","typ":0,"temp":999.00,"min":10.00,"max":62.00,"alarm":true,"color":"#A349A4"},{"number":6,"name":"PulledPork","typ":0,"temp":70.00,"min":10.00,"max":93.00,"alarm":true,"color":"#804000"},{"number":7,"name":"Kanal 7","typ":3,"temp":999.00,"min":10.00,"max":35.00,"alarm":false,"color":"#5587A2"},{"number":8,"name":"Kanal 8","typ":3,"temp":999.00,"min":10.00,"max":200.00,"alarm":false,"color":"#5C7148"}],"pitmaster":{"channel":1,"pid":0,"value":0,"set":50.00,"typ":"off"}}

Ich habe den nano gebrauchsfertig von einem gekauft der ihn aufgebaut hat.

Ich hoffe ihr könnt mit den Infos was anfangen?
 
Zuletzt bearbeitet von einem Moderator:

s.ochs

BOFH
Hi,

mein nano hat mich nie nach nem Update gefragt
liegt dran, dass deine Softwareversion vor v0.9.12 ist. Durch einen notwendigen Serverwechsel sehen die alten Versionen die Updates leider nicht mehr.

und wienes gemacht werden muss wenn kein gelbes Ausrufezeichen Zeichen vorhaben ist.. habe mir hier auch schon einige Sachen erlesenbund getestet, leider ohne Erfolg..
Was genau hast du denn versucht?
Kannst du die Seite IPdesNano/update im Browser aufrufen? Startet das Update, wenn du dort "v1.0.6" einträgst (ohne ") und mit dem Button das Update startest? Genau der gleiche Weg würde auch aktiviert werden, wenn du einen Updatehinweis auf der Startseite hättest, nur, dass die Version, auf die das Update durchgeführt werden soll, im Hintergrund automatisch gewählt wird. Da du den Hinweis nicht hast, musst du das OnlineUpdate manuell starten.

Folgende Daten gibt das nano aus
Ich habe deinen Telegram Token etwas maskiert, nicht das du noch Nachrichten geschickt bekommst ;) Speicher dir die Daten von /data und /settings vor dem Update nochmal kurz wo ab. Bei einem Update von einer so alten Version kann es vorkommen, dass beim Update was verloren geht. Du kannst die Daten zwar nach dem Update nicht automatisch einlesen, aber du kannst sie wieder übers Webinterface einfach eintragen und speichern.

Gruß
Steffen
 

Stoykengesicht

New member
Also soll ich nochmal versuchen die v1.0.6 anzu stoßen? Habe das die ganze Zeit mit v1.0.4 versucht
Post automatically merged:

Also wenn ich das nun anstoßen, zeigt der display,,update webinterface an, startet auch neu und springt dann auf ,,update firmeware um und dann kommt update fehlgeschlagen..
Habe den nano auch mal neben den Router gelegt, leider kein erfolg
 
Zuletzt bearbeitet:

s.ochs

BOFH
Ok. So wie es aussieht, kann dein Nano die Firmware nicht komplett downloaden. Versuch mal bitte folgendes: mach erst ein Update auf v0.9.9 und danach auf v1.0.6 (oder v1.0.4, ist auch ok). Nano in die Nähe vom Router legen und ein Netzteil anschließen.
 

Stoykengesicht

New member
Ok, wird sofort getestet.. moment
Post automatically merged:

Mist leider ohne Erfolg...immer noch fehlgeschlagen...
 

s.ochs

BOFH
Ok, ist selten, kann an der alten Version liegen. Zwei weitere Möglichkeiten:

1. Erzeug mit deinem Handy einen Hotspot. Verbinde dein Nano mit dem Hotspot vom Handy. Nun das OnlineUpdate nochmal anstoßen. Es kann sein, dass das Update über die Verbindung zum Router nicht gezogen werden kann, weil etwas im Netz stört. Am erzeugten Hotspot hängt außer dem Nano nichts dran, was stören kann.

2. wenn das OnlineUpdate nicht klappt, bleibt dir noch das manuelle installieren über die Serielle Schnittstelle. Also Nano per USB-Kabel an einen Windows PC oder einen Mac anschließen. Treiber sollte sich selbst installieren. Danach die Installationsanleitung für die Installation mit dem esptool durchgehen. Dauert etwa 10-15 min. Einfach Schritt für Schritt durchgehen. Der Weg sollte auf jeden Fall funktionieren. Link
 

s.ochs

BOFH
Info zu 1. Dein Nano kann sich mehrere WiFi Netze merken. Wenn du nach dem Update den Hotspot abschaltest, sucht es wieder nach deinem Hauptnetz und verbindet sich. Alternativ kannst du den Hotspot auch mit der SSID und Passwort von deinem Router erzeugen (bei Android geht das, bei iPhone ist die SSID glaub an den Handynamen gekoppelt). Wenn du dann weg von deinem Hauptnetz bist - kurz beim Nachbar vorbeischauen :) - verbindet sich dein Nano automatisch mit dem aktivierten Hotspot.
 

Stoykengesicht

New member
Super danke für den Hinweis

Entweder will das Handy gerade nichtbsonwiebichboder der nano..
Sobald ich nen Hotspot öffne, mich mit dem nano damit verbinden will, verschwinden bei dem nano die vorherigen seid daten(ist ja richtig, weil er ha wechselt) aber es kommen keinen anderen Daten vom Hotspot. Sodas ich ihn neubstarten muss.. ich denke ich gegen Mittag malbinnruhe versuchen das über den Rechner zu machen .. ich hoffe nun schon das ich ihn nicht schrotte
 

s.ochs

BOFH
Ist nur die Software, die lässt sich über die Serielle Schnittstelle immer wieder neu installieren, kannst also nicht wirklich was schrotten. Normalerweise sollte nach dem übermitteln der WiFi Daten das WLAN Icon im Nano Display kurz verschwinden und nach 5-10s ein Hinweis auf die neue IP im neuen Netz kommen, sofern die Verbindung funktioniert hat. Ansonsten mal morgen den beschriebenen Weg mit Hotspot und Daten vom Hauptnetz versuchen. Und bevor du morgen weiter machst, versuch zuerst nochmal das OnlineUpdate, falls was in der Verbindung stört, kann es auch nur temporär sein.
 

Stoykengesicht

New member
😜😜😜😜 Besster support ever....

läuft alles mit 1.0.6 musste zwar neu flashen über den rechner.. aber wenn man wirklich genau nach der anleitung geht, ist das ja easy going.. hammer...
Post automatically merged:

aber ist das richtig das da unter meineip/settings immer noch bei ,,getupdate,, -false- steht? oder kann ich jetzt wie gewohnt die update machen wenn der mir ein gelbes dreieck anzeigt?
 

s.ochs

BOFH
Super!

Ja, ist korrekt. Wenn es ein offizielles Update gibt, dann wird diese Variable mit der Version des Updates gefüllt und das gelbe Dreieck angezeigt. Da es jetzt kein Update gibt, was über deiner Version ist, steht da "false". Nach Updates gesucht wird, so lange "autoupd":"true" ist.
 

s.ochs

BOFH
Gern, danke für deine Geduld. Das OnlineUpdate sollte mit der neuen Firmware jetzt besser laufen. Aber zur Not weißt du jetzt ja auch, wie es manuell geht.
Schönen Sonntag dir noch
Steffen
 
Oben Unten