Ich glaube ich hab's kaputt gemacht

n1chris

New member
Hi zusammen,

letzte Woche habe ich mein Nano bekommen und war grad dabei ein bisschen rum zu testen. Blöderweise habe ich was angestellt und komme jetzt nicht mehr weiter.

Ich habe hier noch einen alte Temperaturfühler liegen und wollte herausfinden welcher Typ es wohl ist. Eingesteckt war dieser in Kanal 6. Dann habe ich in den Einstellungen auch mal das 5K3A1B ausgewählt und gespeichert. Nun wird mir der Kanal nicht mehr in der Übersicht angezeigt. Auch nicht wenn ich einen anderen Fühler einstecke oder das Gerät neu starte. Ist Kanal 6 jetzt für immer kaputt oder kann man hier noch was retten?

Hoffe ihr könnt mir weiter helfen. Ist jetzt nicht so, dass die Welt untergehen würde wenn der Kanal nicht mehr zu retten ist aber schade wäre es allemal.

Vielen Dank schonmal.

Gruß
Chris
 

s.ochs

BOFH
Hi Chris,

einfach alle Fühler abziehen, dann werden dir alle Kanäle im Webinface angezeigt auch Kanal 6, dann den Fühlertyp von Kanal 6 einfach wieder umstellen. Alternativ kannst du auch über das OLED und die Taster direkt am Nano den Typ vom Kanal umstellen.

Bei der Erkennung eines unbekannten Fühlers gehst du besser so vor:
1. mit einem Multimeter den Widerstand des Fühlers bei etwa 25 °C messen. Das ist der Basiswiderstand, anhand dessen kann man schonmal alle Fühlertypen mit nicht gleichem Basiswiderstand aussortieren (siehe Fühlerkennlinien auf Github).
2. den Widerstand in kochendem Wasser messen. Dann diesen Widerstand mit den Kennlininen der verbleibenden Fühlerprofile vergleichen. Es gibt mehrerer NTC-Fühler, die zwar einen gleichen Basiswiderstand haben, deren Kennlinie aber anders verläuft. Deshalb braucht man zur Bestimmung eines Fühlerprofils mindestens 2 Messpunkte. Mehr sind natürlich besser, aber schwierig. Wenn sich ein unbekannter Fühler bei zwei Messpunkten mit eins der bekannten Fühlerprofile deckt, ist die Wahrscheinlichkeit groß, dass das Profil passend ist.

Gruß
Steffen
Post automatically merged:

Falls du als Softwareversion die v1.0.4 drauf hast, dann mach am besten einen Reset auf Werkseinstellungen. Dafür gibst du im Browser IPdesNano/configreset ein und bestätigst. Solltest du schon Einstellungen bei Telegram etc. gemacht haben, speicherst du dir die Daten am besten kurz wo zwischen. Du kannst dir entweder Screenshots von den Einstellungen machen oder du rufst IPdesNano/settings auf und speicherst die Textausgabe zwischen. In der v1.0.4 ist ein kleiner Software-Bug, der bei dem Fühlerprofil 5K3A1B den Kanal blockt.
Alternativ kannst du per IPdesNano/update auch ein Update auf die PreRelease-Version v1.0.6 machen, der Kanal müsste dann wieder einstellbar sein.
 

n1chris

New member
Hi Steffen,

danke danke danke... Auf den Trichter alle Fühler zu entfernen bin ich natürlich nicht gekommen. Jetzt geht aber wieder alles. :)

Ich habe es mir natürlich einfach gemacht. Habe bekannte Fühler angeschlossen und so wusste ich welche Temperatur angezeigt werden müsste. Und so habe ich bei dem unbekannten Fühler alles durchprobiert in der Hoffnung auch auf den gleichen Wert zu kommen. Deine Methode ist natürlich durchaus intelligenter und präziser :)

Ich habe übrigens mit /settings raus gefunden, dass ich bereits die v1.0.6 drauf habe vom Werk aus. Müsste dann ja bedeuten, dass hier der Bug auch noch existiert.

Wie dem auch sei. Vielen Dank nochmal für die schnelle Hilfe. Ich hoffe ich finde bald ein bisschen Zeit das Moped mal in Aktion zu sehen :cool:

Viele Grüße
Chris
 

s.ochs

BOFH
Hi Chris,

super, dass sich das Problem direkt beheben lies.

Ich habe übrigens mit /settings raus gefunden, dass ich bereits die v1.0.6 drauf habe vom Werk aus. Müsste dann ja bedeuten, dass hier der Bug auch noch existiert.
Nein, der Bug in der v1.0.4 hätte sich anders gezeigt. Du konntest ja problemlos einen anderen Fühltertyp auswählen, nachdem du alle Fühler abgezogen hast. Das ist so gedacht. Bei dem 5K3A1B ist es einfach so, dass der einen sehr tiefen Basiswiderstand von 5kOhm hat. Wenn man da nicht einen Fühler mit passendem Basiswiderstand nutzt, kommt da nie eine Anzeige, weil die berechneten Temperatur weit weg von gut und böse sind.

Das Vergleichen mit einem anderen Fühler ist natürlich auch machbar, sofern man einen Fühler hat, von dem man weiß welches Profil er hat. Wenn man nach den Widerständen geht, sieht man eben direkt auf den ersten Blick, welche Profile überhaupt in Frage kommen.

Gruß
Steffen
 
Oben Unten